Вопрос по информатике:
Здравствуйте!Помогите пожалуйста с информатикой!Заранее большое спасибо!
Необходимое задание:
Написать программу,которая выводит суммы главной диагонали, верхней треугольной матрицы и нижней треугольной.
Язык программирования(Английский)(Обычный)
- 04.01.2017 23:28
- Информатика
- remove_red_eye 14582
- thumb_up 8
Ответы и объяснения 2
-----------
#include #include #include using namespace std;int main(){ srand(time(0)); int mas[5][5]; int sum=0,sum1=0,sum2=0; for(int i=0;i<5;i++){ for(int j=0;j<5;j++){ mas[i][j]=10+rand()%50; } } for(int i=0;i<5;i++){ for(int j=0;jj)sum1+=mas[i][j]; if(i
- 05.01.2017 22:47
- thumb_up 20
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество строк (столбцов) в матрице:');
Writeln('*** Исходная матрица ***');
var a:=MatrRandom(n,n,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
var (su,sd,sl):=(0,0,0);
for var i:=0 to n-1 do
for var j:=0 to n-1 do
if i
if i=j then sd+=a[i,j]
else sl+=a[i,j];
Writeln('Суммы элементов:');
Writeln(' - верхней треугольной матрицы ',su);
Writeln(' - главной диагонали ',sd);
Writeln(' - нижней треугольной матрицы ',sl)
end.
Пример
Количество строк (столбцов) в матрице: 4
*** Исходная матрица ***
-73 -89 4 39
77 -32 23 -45
-29 -70 -88 -40
-83 9 21 -46
----------------
Суммы элементов:
- верхней треугольной матрицы -108
- главной диагонали -239
- нижней треугольной матрицы -75
"Школьный" вариант
const
nn=20; { максимальный размер }
var
a:array[1..nn,1..nn] of integer;
i,j,n:integer;
su,sd,sl:longint;
begin
Write('Количество строк (столбцов) в матрице:');
Readln(n);
Randomize;
Writeln('*** Исходная матрица ***');
su:=0; sd:=0; sl:=0;
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=Random(199)-99;
Write(a[i,j]:4);
if i
if i=j then sd+=a[i,j]
else sl+=a[i,j]
end;
Writeln
end;
Writeln('Суммыа элементов:');
Writeln(' - верхней треугольной матрицы ',su);
Writeln(' - главной диагонали ',sd);
Writeln(' - нижней треугольной матрицы ',sl)
end.
- 06.01.2017 22:34
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.