Вопрос по информатике:
Даны x,y,z. Напишите программу для вычисления значения арифметических выражений .
1.a=x+y-z/x2+2
2.a=5 2x-z/3+y2
(/ дробь)
- 04.10.2017 01:48
- Информатика
- remove_red_eye 15728
- thumb_up 33
Ответы и объяснения 1
Var x, y, z: integer; a1, a2: real;
Begin
Writeln('Введите значения х, y, z');
Readln(x, y, z);
a1 := (x + y - z) / (x * 2 + 2);
a2 := 5 * ((2 * x - z) / (3 + y * 2));
Writeln();
Writeln('a1 = ', a1);
Writeln('a2 = ', a2);
End.
-----------------------
P.S. Программа на паскале; На будующее - пиши условие задачи понятнее. Не х2, а х * 2 или 2х, а то это можно посчитать как х^2
Ответ к заданию 1 - это а1, а к заданию 2 - это а2
- 05.10.2017 18:25
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.