Вопрос по информатике:
Напишите программу которая для введённой пары положительных чисел, большее число делит на меньшее до того, пока оно не станет меньше единицы
- 25.10.2015 12:55
- Информатика
- remove_red_eye 7439
- thumb_up 7
Ответы и объяснения 2
a,b,t:real;
begin
Write('Введите через пробел два положительных числа: ');
Read(a,b);
if b>a then begin t:=a; a:=b; b:=t end;
repeat
a:=a/b
until a<1;
Writeln(a)
end.
Пример
Введите через пробел два положительных числа: 1.7 153.4
0.760915000615007
- 27.10.2015 22:56
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.