Вопрос по информатике:
Даны первые элементы последовательности чисел 4.7.10.13...
составьте программу которая вычислит и выведет на экран монитора сумму элементов заданной последовательности значение которых меньше 25
на паскале))
- 13.10.2017 02:07
- Информатика
- remove_red_eye 1345
- thumb_up 28
Ответы и объяснения 1
Var
a1, a2, d, k, max, tmp: integer;
sum: real;
rule: boolean;
Begin
Writeln('Введите а1 и а2');
Readl(a1, a2);
k := 2;
d := a2 - a1;
rule := true;
while (rule = true) do
begin
k := k + 1;
tmp := a1 + k * d;
if (tmp < 50) then
max := tmp
else
rule := false;
end;
sum := (a1 + max) / 2 * k;
Writeln();
Writeln('Сумма = ', sum);
End.
------------------------
Программа будет работать только для арифметических прогрессий, например, таких, как последовательность из задания. Вводить нужно 2 целых числа (первые два члена прогрессии) через пробел (в вашем случае 4 и 7)
- 14.10.2017 22:32
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.