Вопрос по информатике:
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr(x)+x/3+sqr(sin(x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3: Составить программу на языке Паскаль, которая переставляет местами цифры в двухзначном числе (например 75 заменит на 57)
- 12.11.2017 22:29
- Информатика
- remove_red_eye 13063
- thumb_up 22
Ответы и объяснения 1
var
x:real;
begin
Readln(x);
Writeln('y = ', sqr(x)+x/3+sqr(sin(x)));
end.
2)
var
p,a,b,c:real;
begin
Readln(a,b,c);
p:= (a+b+c)/2;
Writeln('S = ', sqrt(p*(p-c)*(p-b)*(p-a)));
end.
3)
var
a:integer;
begin
Readln(a);
a:= a div 10 + (a mod 10)*10;
Writeln(a);
end.
- 13.11.2017 03:14
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.