Вопрос по информатике:
Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матрицы
- 16.01.2018 08:36
- Информатика
- remove_red_eye 3947
- thumb_up 15
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
Writeln('*** Исходная матрица ***');
var a:=MatrRandom(m,n,-99,99); a.Println(4); Writeln;
Writeln('Max=',a.ElementsByRow.Max)
end.
Пример
Количество строк и столбцов в матрице: 5 8
*** Исходная матрица ***
37 27 -8 -40 -85 -36 62 90
-60 -14 -18 0 -50 77 -19 -36
14 -98 -80 81 -8 83 84 26
-65 74 12 -77 -84 -4 -51 -93
94 34 45 23 -53 -55 55 -45
Max=94
- 18.01.2018 00:52
- thumb_up 9
- 18.01.2018 22:50
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.