Вопрос по информатике:
Написать программу в паскале. Входные данные : вводятся 4 числа, а, b, C, d
Выходные данные : найдите все целые решения уравнения ax^3+bx^2+cx+d=0 на отрезке [0,1000] и выведите их в порядке возрастания. Если на данном отрезке нет ни одного решения, то ничего выводить не нужно.
- 16.08.2017 17:43
- Информатика
- remove_red_eye 2364
- thumb_up 42
Ответы и объяснения 1
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var (a,b):=ReadInteger2('Введите a,b,c,d->');
var (c,d):=ReadInteger2;
Write('Корни: ');
for var x:=0 to 1000 do
if a*x**3+b*x**2+c*x+d=0 then Write(x,' ');
end.
Пример:
Введите a,b,c,d-> 1 -3 -13 15
Корни: 1 5
- 17.08.2017 02:05
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.