Вопрос по информатике:
СРОЧНО!!!!СРОЧНО!!!!!!ОЧЕНЬ!!!!ОЧЕНЬ!!!!!
написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 24.01.2017 01:54
- Информатика
- remove_red_eye 16486
- thumb_up 49
Ответы и объяснения 1
Она на Pascal.
var a,last_num,first_num:integer;
begin
Write('Введите число');
read(a);
last_num:=a mod 10;
first_num:=a;
while first_num>10 do
begin
first_num:= first_num div 10;
end;
writeln('Последняя цифра ', last_num, ', Первая цифра ', first_num);
if first_num > last_num then
writeln('Первая цифра больше')
else if first_num = last_num then
writeln('Они равны')
else if last_num > first_num then
writeln('Последняя цифра больше');
end.
- 26.01.2017 00:40
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.