Вопрос по информатике:
Паскаль
1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры).
2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа. Написать программу поиска таких чисел.
3. Составить программу для проверки, можно ли заданное натуральное число N представить в виде произведения двух простых чисел.
- 03.10.2015 04:07
- Информатика
- remove_red_eye 16324
- thumb_up 16
Ответы и объяснения 1
var
a,b,sum : integer;
begin
Readln(a, b);
if (a mod b = 0) then
begin
while a > 0 do
begin
sum:= sum + (a mod 10);
a:= a div 10;
end;
if sum > b then
begin
Writeln('Верно');
halt;
end;
end;
Writeln('Неверно');
end.
Пример:
1234 2
Верно
2)
var
i: integer;
begin
For i:= 100 to 999 do
if (i*i)mod 1000 = i then Write(i, ' ');
end.
Результат:
376 625
3)
var
i,n : integer;
function Simple(n: Longint): boolean;
var
i: Longint;
begin
for i := 2 to Round(Sqrt(n)) do
if n mod i = 0 then
break;
Simple := n mod i 0;
end;
begin
Read(n);
For i:= 1 to Round(Sqrt(n)) do
if n mod i = 0 then
if (Simple(i))and(Simple(n div i)) then
begin
Writeln('YES');
halt;
end;
Writeln('NO');
end.
Пример:
33
YES
- 04.10.2015 18:16
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.