Вопрос по информатике:
Пожалуйста добрые люди помогите 80б!!!Решить данную задачу на Паскале
Напишите программу, чтобы создавала палиндром любой строки. Палиндром - исходная строка + обратное представление строки (на входе – abc; на выходе abccba)
- 04.09.2017 07:14
- Информатика
- remove_red_eye 1893
- thumb_up 38
Ответы и объяснения 1
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
s:=s+s.Inverse;
s.Println
end.
Пример
abc
abccba
2. Так все еще учат в большинстве (но уже не во всех!) школ
program Palindrom;
var
s:string;
i,n:integer;
begin
Readln(s);
for i:=Length(s) downto 1 do s:=s+s[i];
Writeln(s)
end.
- 05.09.2017 14:11
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.