Вопрос по информатике:
Напишите программу, в которой сортировка выполняется методом камня- самый тяжелый элемент опускается в конец массива. в решение в паскаля
- 26.01.2018 18:45
- Информатика
- remove_red_eye 18447
- thumb_up 21
Ответы и объяснения 1
//FIXED
var
a:array[1..10000] of integer;
i,m,n,fl, tmp : integer;
Begin
Writeln('Введите кол-во элементов в массиве');
Readln(n);
Writeln('Введите элеметы массива: ');
for i:= 1 to n do
Read(a[i]);
m:=n;
repeat
fl:= m; m:= 0;
for i:=1 to fl-1 do
if a[i+1] < a[i] then
begin
m:=i;
tmp:=a[i];
a[i]:=a[i+1];
a[i+1]:=tmp;
end;
until m=0;
for i:= 1 to n do
Write(a[i], ' ');
end
- 27.01.2018 20:04
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.