Вопрос по информатике:
Составить программу в паскаль, где при вводе любого трехзначного числа в результате все цифры этого числа записаны через запятую.Пожалуйста
Например
Введите трехзначное число 123
Результат 1,2,3
- 20.10.2017 04:25
- Информатика
- remove_red_eye 11885
- thumb_up 8
Ответы и объяснения 2
var
s:string;
begin
Write('Введите трехзначное число -> ');
readln(s);
Write('Результат -> ',s[1], ',');
write(s[2], ',');
Write(s[3]);
end.
Пример:
Введите трехзначное число -> 453
Результат -> 4,5,3
- 21.10.2017 12:56
- thumb_up 45
var a: integer;
begin
write('Введите трехзначное число: ');
readln(a);
write('результат: ',a div 100,',',a mod 100 div 10,',',a mod 10);
end.
- 23.10.2017 00:41
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.