Вопрос по информатике:
Составить алгоритм вычисления стоимости поездки на автомобиле на дачу туда и обратно если известно расстояние до дачи(км),кол-во бензина потребляемого автомобилем на 100 км пробега и цена 1 литра бензина.
- 02.09.2015 17:09
- Информатика
- remove_red_eye 3328
- thumb_up 11
Ответы и объяснения 1
Объявляем 4 переменные вещественного типа и считываем их.
Выводим математическую формулу, для вычисления стоимости.
Количество бензина на 1 км пути * удвоенное расстояние до дачи * цена бензина.
-----------------------------------------------------------------------------------------
Ниже приведена программа на языке Паскаль
-----------------------------------------------------------------------------------------
var
S, count, price, ans:real;
Begin
Writeln('Введите расстояние до дачи -> ');Readln(s);
Writeln('Введите расход бензина на 100 км пути -> ');Readln(count);
Writeln('Введите цену бензина -> ');Readln(price);
ans:= ((count/100)* 2*s * price );
Writeln('Стоимость поездки: ', ans);
end.
-----------------------------------------------------------------------------------------
Пример:
Введите расстояние до дачи ->
28.54
Введите расход бензина на 100 км пути ->
13.1
Введите цену бензина ->
45
Стоимость поездки: 336.4866
- 03.09.2015 14:22
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.