Вопрос по информатике:
Дано натуральное число N (N<=109). Определить порядковый номер его минимальной цифры, считая от начала числа (если таких цифр несколько, то вывести номер первой встретившейся)
Пример входных и выходных данных
№ теста Входные данные Выходные данные
1 45545 1
2 100 2
НА С++
- 14.11.2015 16:46
- Информатика
- remove_red_eye 14924
- thumb_up 25
Ответы и объяснения 1
using namespace std;
int main()
{
string s;
cin >> s;
int ans = -1;
char MIN = '9' + '0';
for (int i = 0; i < s.length(); ++i)
if (s[i] < MIN)
{
MIN = s[i];
ans = i;
}
cout << ans + 1;
}
// +1 т.к. индексация с нуля
Пример:
450
3
- 15.11.2015 19:53
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.