Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет сумму положительных чисел, кратных 5. Программа получает на вход целые числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0. Кол-во чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число:сумму положительных чисел, кратных 5.
Пример работы программы:
Входные данные :-25;45;20;1;0.
Выходные данные:65.
P.S. учительница сказала найти сумму, кол-во,произв."max,min.
- 01.10.2017 16:52
- Информатика
- remove_red_eye 9874
- thumb_up 29
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var (s,k,p,mx,mn):=(0,0,BigInteger(1),-30001,30001);
ReadSeqIntegerWhile(t->t0).Where(t->(t>0) and (t mod 5=0))
.Foreach(t->begin s+=t; k+=1; p*=t; mx:=Max(mx,t); mn:=Min(mn,t) end);
Writeln('S=',s,', K=',k,', П=',p,', min=',mn,', max=',mx)
end.
Пример
9095 -15199 5068 5310 2534 1136 11454 -17910 3480 -23949 24356 -5077 27301 -25057 -5789 24995 -16013 -5246 -5168 16256 17565 -24551 -229 22412 -3274 20445 3399 -11620 -21875 -18607 0
S=80890, K=6, П=1508567956180663412250000, min=3480, max=24995
- 03.10.2017 00:31
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
