Вопрос по информатике:
Нужна помощь с информатикой. 35 баллов.
1. Определите значение переменной S после выполнения алгоритма:
x:=340
y:=5
x:=x div y
y:=x mod y
x:=x-5
y:=y+3
s:=x+y
2. Определите значение переменной а после выполнения данного алгоритма.
a:=3
b:= -1
b:=9+a*b
a:= (b*b)/(b/a)
Все обязательно в таблицах. Заранее спасибо.
- 19.11.2015 18:49
- Информатика
- remove_red_eye 7868
- thumb_up 5
Ответы и объяснения 1
var x,y,S:integer;
begin
x:=340;
y:=5;
x:=x div y;
y:=x mod y;
x:=x-5;
y:=y+3;
S:=x+y;
writeln(S);
end.
Ответ получился 69
2) var a, b:real;
begin
a:=3;
b:=-1;
b:=9+a*b;
a:=(b*b)/(b/a);
writeln(a);
end.
Ответ получился 18
- 20.11.2015 03:31
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.