Вопрос по информатике:
Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа и количество введенных чисел неизвестно последовательность чисел заканчивается числом 0. Количество чисел не превышает 1000 . Введенные числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2.
Входные данные: 112, 24, 42, 49, 22,0
Выходные данные: 154
- 27.08.2017 07:14
- Информатика
- remove_red_eye 19204
- thumb_up 21
Ответы и объяснения 2
var s,x:integer;
begin
s:=0;
x:=1;
while x0 do
begin
read(x);
if (x mod 7=0) and (i mod 10=0) then s:=x+s;
end;
writeln('summa=',s);
end.
- 28.08.2017 04:13
- thumb_up 36
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadlnString.ToIntegers.Where(t -> (t mod 7 = 0) and (t mod 10 = 2)).sum);
end.
- 29.08.2017 11:09
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.