Вопрос по информатике:
Написать программу :
в последовательности натуральных чисел найти сумму и кол-во дву значных чисел начинающихся на 2
Program - Pascal ABC
- 04.09.2018 13:44
- Информатика
- remove_red_eye 14885
- thumb_up 9
Ответы и объяснения 2
var x,y,i:integer;
var a:array [1..9999] of integer;
Begin
y:=0;
write('введите количество чисел (макс 9999): ');
readln (x);
write('Масив: ');
for i:=1 to x do
begin
a[i]:=random(89)+10;
write(a[i],', ');
end;
writeln('');
for i:=1 to x do
begin
if (a[i] div 10 =2) then
begin
y:=a[i]+y;
writeln('Подходящее число:',a[i],' сумма =',y );
end;
end;
writeln('конец');
end.
- 05.09.2018 21:35
- thumb_up 31
var
i,n,cnt,tmp,sum, last:integer;
a:array [1..9999] of integer;
Begin
Writeln('Введите кол-во элементов');
Readln(n);
Writeln('Введите последовательность -> ');
for i:= 1 to n do
read(a[i]);
writeln();
for i:=1 to n do
begin
tmp:= a[i];
while tmp > 0 do
begin
last:=tmp mod 10;
tmp:= tmp div 10;
end;
if last = 2 then
begin
cnt:= cnt + 1;
sum:= sum + a[i];
end;
end;
Writeln('Всего элементов: ', cnt);
Writeln('Сумма равна ', sum);
end.
- 06.09.2018 14:30
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.

