Вопрос по информатике:
Помогите с задачей по информатике прошу вас. Срочно. На паскале или на C++. Желательно все-таки на паскале
Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Даны два числа A и B (0<=A,B<=100000). Напишите программу нахождения произведения числа А на все цифры числа В. Входной файл input.txt содержит два числа A и B. В выходной файл output.txt вывести одно число – произведение числа А на все цифры числа В.
Ввод 3 33
Вывод 27
- 08.08.2018 06:39
- Информатика
- remove_red_eye 2570
- thumb_up 12
Ответы и объяснения 2
a,b:int64;
Begin
Read(a, b);
if b = 0 then Writeln(0)
else begin
While b > 0 do begin
a:= a * (b mod 10);
b:= b div 10;
end;
Writeln(a);
end;
end.
- 09.08.2018 07:14
- thumb_up 31
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadInteger2;
if b=0 then Writeln(0)
else begin
var p:int64:=a;
while b>0 do begin
p*=b mod 10;
b:=b div 10
end;
Writeln(p)
end
end.
Пример
2342 8945923
182113920
- 01.01.1970 00:00
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.