Вопрос по информатике:
Напишите программу вычисления наименьшего общего кратного в следующих четырех чисел : 36,54,18 и 15 . Используйте процедуру вычисления наибольшего общего делителя двух чисел.
- 26.08.2017 13:31
- Информатика
- remove_red_eye 15269
- thumb_up 40
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function HOK(a,b:integer):integer;
begin
Result:=a*b;
while b>0 do (a,b):=(b,a mod b); // a - НОД
Result:=Result div a
end;
begin
Writeln('НОК(36,54,18,15)=',HOK(HOK(36,54),HOK(18,15)))
end.
Результат
НОК(36,54,18,15)=540
- 27.08.2017 22:37
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.