Вопрос по информатике:
Напишите программу, которая будет выводить на экран последовательность Фибоначчи. Первые два члена последовательности и количество выводимых на экран членов пользователь должен ввести с клавиатуры (c++)
- 16.03.2018 08:06
- Информатика
- remove_red_eye 13465
- thumb_up 35
Ответы и объяснения 1
int main(){ int n;
std::cin >> n;
int a = 1; int b = 1;
for(int i = 0; i < n; i++) { std::cout << (i % 2 == 0 ? a : b) << std::endl;
if(i % 2 == 0) a += b; else b += a; }
return 0;}
- 17.03.2018 18:18
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.