Вопрос по информатике:
Написать программу, которая генерирует 10 четных чисел и сортирует их по возрастанию.
Точного промежутка чисел в условии нет, но я думаю, можно поставить свое - например, 100
- 23.11.2016 00:31
- Информатика
- remove_red_eye 16361
- thumb_up 26
Ответы и объяснения 1
arr = array[1..10] of integer;
const //числа, которые генерируются (от 0 до d-1)
d = 101;
var //массив, хранящий сгенерированные числа
a: arr;
procedure Sort(var arg: arr); //сортирует массив по возрастанию
var
t: integer;
begin
for var i := 1 to 9 do
for var j := 1 to 9 do
if arg[j] > arg[j + 1] then begin
t := arg[j];
arg[j] := arg[j + 1];
arg[j + 1] := t;
end;
end;
begin
randomize();
for var i := 1 to 10 do a[i] := Random(d); //генерация рандомных чисел (0..d-1)
Sort(a); //сортировка массива
for var i := 1 to 10 do write(a[i], ' '); //вывод массива
end.
- 23.11.2016 22:46
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.