Вопрос по информатике:
Вычислить 15 элементов, которые получены в результате вычисления арифметического выражения: Y= , где xÎ [0.75;3] с шагом = 0.2.Вычислить все значения и найти количество элементов <0.1
Нужна блок-схема и программа в паскале.
- 25.08.2017 01:06
- Информатика
- remove_red_eye 10675
- thumb_up 12
Ответы и объяснения 2
{
Вычислить 15 элементов, которые получены в результате вычисления арифметического выражения:
Y=sqrt(x)*sin(x)/2 , где x [0.75;3] с шагом = 0.2.Вычислить все значения и найти количество элементов <0.1
}
CONST
min = 0.75;
max = 3;
stp = 0.2;
val = 0.1;
var j:byte;
zr, ir:real;
BEGIN
j := 1;
ir := min;
while ir<=max do begin
zr := sqrt(ir)*sin(ir)/2;
if (zr
writeln('x=',ir,' y=',zr);
ir := ir+stp;
end;
writeln('количество элементов y < ',val,' = ',j-1);
END.
- 26.08.2017 21:27
- thumb_up 30
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var x:=0.75;
var kol:=0;
while x<=trunc(3+0.2/2) do
begin
var y:=sqrt(x)*sin(x)/2;
Write('x=',x,' ');Writeln('y=',y);
x:=x+0.2;
if y<0.1 then inc(kol);
end;
Println('Количество y<0.1=',kol);
end.
Результат:
x=0.75 y=0.295158241192166
x=0.95 y=0.39640968210305
x=1.15 y=0.489415138771753
x=1.35 y=0.566844047305235
x=1.55 y=0.622360374192837
x=1.75 y=0.650845527252713
x=1.95 y=0.648610822565261
x=2.15 y=0.613567255886829
x=2.35 y=0.545333998474535
x=2.55 y=0.445274740480793
x=2.75 y=0.316456576938099
x=2.95 y=0.163530818695244
Количество y<0.1 0
- 27.08.2017 10:12
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.

