Вопрос по информатике:
2. Укажите наибольшее и наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 7.
var x, a, b : integer;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
a := a + 1;
b := b + (x mod 6);
x := x div 6;
end;
writeln(a); write(b);
end.
- 23.02.2018 15:44
- Информатика
- remove_red_eye 14693
- thumb_up 19
Ответы и объяснения 1
var x, a, b : integer;
begin
for var i:=0 to MaxInt do
begin
a := 0; b := 1;
x:=i;
while x > 0 do
begin
a := a + 1;
b := b + (x mod 6);
x := x div 6;
end;
If (a=3) and (b=7) then Println(a,b,i);
end;
end.
Результат:
3 7 41
3 7 46
3 7 51
3 7 56
3 7 61
3 7 66
3 7 76
3 7 81
3 7 86
3 7 91
3 7 96
3 7 111
3 7 116
3 7 121
3 7 126
3 7 146
3 7 151
3 7 156
3 7 181
3 7 186
Судя с результата, ответ: Минимальное - 41, Максимальное - 186
- 24.02.2018 22:05
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.