Вопрос по информатике:
Помогите решить задачу по С++ :Пользователь вводит с клавиатуры 7 целых чисел. Написать программу, которая определяет максимальное из этих 7 чисел(через if, else).
- 07.05.2018 10:32
- Информатика
- remove_red_eye 15486
- thumb_up 25
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int a[7];
int MAX = -1000*1000*1000-13;
for (int i = 0; i < 7; ++i)
cin >> a[i];
if (a[0] > MAX)
MAX = a[0];
if (a[1] > MAX)
MAX = a[1];
if (a[2] > MAX)
MAX = a[2];
if (a[3] > MAX)
MAX = a[3];
if (a[4] > MAX)
MAX = a[4];
if (a[5] > MAX)
MAX = a[5];
if (a[6] > MAX)
MAX = a[6];
cout << MAX;
}
- 08.05.2018 09:39
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.