Вопрос по информатике:
Написать программу с помощью языка программирования Паскаль по нахождению ответа на вопрос: войдет ли круг диаметром D в прямоугольную рамку размером а на b
Составить программу
ПРОСТО МОЛЮ, СКАЖИТЕ КАК РЕШАТЬ, ПОЖАЛУЙСТА, ЖЕЛАТЕЛЬНО С ПОДРОБНЫМ РЕШЕНИЕМ!!!
9 КЛАСС
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 03.12.2015 06:26
- Информатика
- remove_red_eye 18076
- thumb_up 27
Ответы и объяснения 2
begin
readln(a,b);
readln(D);
if (D<=a) and (D<=b) then writeln('YES')
else writeln('NO');
end.
- 04.12.2015 11:45
- thumb_up 22
По этому решению составляем алгоритм:
1. Ввести a, b, D
2. Найти m - минимум (a,b)
3. Если D
Осталось написать программу.
1. Современное решение
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,d):=ReadReal3('Введите через пробел a,b,D:');
var m:=Min(a,b);
if D
end.
Пример
Введите через пробел a,b,D: 14.5 11 10.6
Войдет
2. "Школьный" вариант - так писали наши отцы и деды
var
a,b,D,m:real;
begin
Write('Введите через пробел a,b,D: ');
Read(a,b,d);
if a else m:=b;
if D
end.
- 05.12.2015 09:17
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.