Вопрос по информатике:
1. Имеется пронумерованный список деталей: 1) шуруп, 2) гайка, 3) винт, 4) гвоздь, 5) болт. Составить программу, которая по номеру детали выводит на экран ее название. С++
- 07.04.2018 00:02
- Информатика
- remove_red_eye 10516
- thumb_up 46
Ответы и объяснения 2
#include
#include
using namespace std;
void main()
{
setlocale(LC_ALL, "Russian");
system("title Материалы");
system("color 74");
int material;
start:
system("CLS");
cout << "Введите число для уточнение названия детали:\n";
cin >> material;
switch (material)
{
case 1: cout <<"Шуруп\n";
break;
case 2: cout<<"Гайка\n";
break;
case 3: cout<<"Винт\n";
break;
case 4: cout<<"Гвоздь\n";
break;
case 5: cout<<"Болт\n";
break;
default: cout<<"Предмет не найден\n";
break;
}
getch();
goto start;
}
- 08.04.2018 13:09
- thumb_up 15
#include
void main(void)
{
clrscr();
int detal;
a:printf(«для получения названия детали введите номер (от 1 до 5) «);
scanf(«%d»,&detal);
switch(detal)
{
case 1:
printf(«шуруп»);
break;
case 2:
printf(«гайка»);
break;
case 3:
printf(«винт»);
break;
case 4:
printf(«гвоздь»);
break;
case 5:
printf(«болт»);
break;
default:
printf(«Ошибка ввода»);
goto a:
}
getch();
}
- 09.04.2018 23:03
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.