Вопрос по информатике:
Помогите, пожалуйста, написать программу на языке С
Программа должна считывать последовательность 25 чисел из файла, заменить все элементы, которые меньше среднего арифметического этих элементов, на 0 и вывести новую последовательность в новый файл
- 16.03.2018 15:35
- Информатика
- remove_red_eye 14682
- thumb_up 52
Ответы и объяснения 1
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58
- 17.03.2018 06:46
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.