Вопрос по информатике:
Даю 50 баллов!!!Изумруды
У царя было семь сыновей. В сундуке лежали изумруды. Пришел первый сын и взял половину того, что было. Пришел второй сын и взял половину того, что осталось и т.д. Каждый из сыновей приходил и забирал половину того, что осталось. Наконец, пришел последний, седьмой сын и увидел почти пустой сундук – с двумя последними изумрудами. Сколько изумрудов было первоначально?
Составить программу (pascal). Даю 50 баллов!!!!
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 04.03.2017 03:13
- Информатика
- remove_red_eye 16557
- thumb_up 41
Ответы и объяснения 1
BEGIN
k:=1;
For i:=1 to 7 dok:=k*2;
Writeln('В сундуке было ',k,' изумрудов');
END.
- 05.03.2017 09:48
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.