Вопрос по информатике:
Составьте программу, котоая печатает слово true, если указанное высказываени является истинным, и false в противном случае цифры исходного четырехзначного числа N образуют строго возрастающую последовательность входные данные на вход подается число N (1000<=N<=9999) выходные данные true - если все цифры числа образуют строго возрастающую последовательность false - в противном случае ПРИМЕР: вход: 1234 вывод: true ПРИМЕР: вход: 1224 вывод: false вот моя программа { int N, a, b, c, d; scanf("%d",&N); a=N%10; b=N/10%10; c=N/100%10; d=N/1000; if ( b==a+1 && c==a+2 && d==a+3) printf("true"); else printf("false"); } в любом случае выводит фолс
- 21.08.2018 22:18
- Информатика
- remove_red_eye 6764
- thumb_up 27
Ответы и объяснения 2
заменить на следующий
if ((a>b) && (b>c) && (c>d)) printf("true");
- 22.08.2018 16:26
- thumb_up 36
ИСПОЛЬЗУЕТ Вывод ИЗ "...\Отделы\Обмен\\, Приём ИЗ "...\Отделы\Обмен\";br />
ПЕР
число: ЦЕ
- 23.08.2018 00:24
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.