Вопрос по информатике:
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет.(На Паскале)
Входные данные
Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).
Выходные данные
Программа должна вывести слово YES, если точки находятся в одной координатной четверти, в противном случае вывести слово NO.
Примеры
Входные данные
3
3
5
1
Выходные данные
YES
Паскаль
- 03.01.2018 00:26
- Информатика
- remove_red_eye 10518
- thumb_up 43
Ответы и объяснения 2
var x1,y1,x2,y2:real;
begin
readln(x1,y1);
readln(x2,y2);
if (x1*x2>0)and(y1*y2>0) then writeln('YES')
else writeln('NO');
end.
Пример:
3 3
5 1
YES
- 03.01.2018 19:26
- thumb_up 8
// Внимание! Если программа не работает, обновите версию!
begin
var (x1,y1):=ReadReal2('Введите координаты 1-й точки:');
var (x2,y2):=ReadReal2('Введите координаты 2-й точки:');
if (Sign(x1)=Sign(x2)) and (Sign(y1)=Sign(y2)) then Writeln('YES')
else Writeln('NO')
end.
Примеры
Введите координаты 1-й точки: 3 3
Введите координаты 2-й точки: 5 1
YES
Введите координаты 1-й точки: -2.6 3.2
Введите координаты 2-й точки: -3 -0.14
NO
- 04.01.2018 00:37
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.