Вопрос по информатике:
Написать программу в паскале позволяющую найти среднее арифметическое элементов массива состоящего из 10 чисел которые превышают число C. Спасибо
- 17.10.2016 06:36
- Информатика
- remove_red_eye 1907
- thumb_up 47
Ответы и объяснения 1
begin
var a:=ArrRandom(10,1,50); a.Println;
var c:=ReadInteger('c = ');
var s:=a.Where(x->x>c);
if s.Count>0 then
writeln('Среднее арифметическое элементов > ',c,' = ',s.Average)
else writeln('В массиве нет искомых элементов');
end.
Пример:
8 2 22 16 24 34 29 16 1 26
c = 50
В массиве нет искомых элементов
2.
const n=10;
var a:array[1..n] of integer;
c,i,s,k:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(51);
write(a[i],' ');
end;
writeln;
write('c = ');
readln(c);
s:=0; k:=0;
for i:=1 to n do
if a[i]>c then begin s:=s+a[i]; k:=k+1; end;
if k>0 then writeln('Среднее арифметическое элементов > ',c,' = ',s/k:5:2)
else writeln('В массиве нет искомых элементов');
end.
Пример:
39 38 43 25 45 16 16 12 35 16
c = 40
Среднее арифметическое элементов > 40 = 44.00
- 18.10.2016 15:34
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.