Вопрос по информатике:
РЕШИТЕ ЗАДАЧУ В ПАСКАЛЕ,ПОЖАЛУЙСТА!
напишите программу,которая заполняет массив из N элементов случайными целыми числами в диапазоне [A,B] и определяет количество элементов этого массива,у которых сумма цифр равна K.
- 27.05.2018 07:55
- Информатика
- remove_red_eye 19391
- thumb_up 40
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function sn(n:integer):integer; // сумма цифр числа
begin
n:=Abs(n);
Result:=0;
while n>0 do begin
Result+=n mod 10;
n:=n div 10
end
end;
begin
var (n,a,b):=ReadInteger3('Введите n,a,b через пробел:');
var m:=ArrRandom(n,a,b); m.Println;
var k:=ReadInteger('k=');
Writeln('Найдено чисел: ',m.Where(t->sn(t)=k).Count)
end.
Пример
Введите n,a,b через пробел: 15 -50 60
43 2 42 -26 -34 57 45 44 29 -41 -4 1 -17 38 -19
k= 7
Найдено чисел: 2
- 28.05.2018 11:19
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.