Вопрос по информатике:
Составить программу на паскале. Расчитать доход за весь гот по месяцам. пример: в первый месяц мы получили 100р, во второй 102р. Но! учесть что и проценты тоже растут.
- 22.02.2017 01:50
- Информатика
- remove_red_eye 7651
- thumb_up 50
Ответы и объяснения 1
// Cборка 1590 от 03.12.2017
begin
var a:=ReadReal('Введите зарплату в первый месяц->');
var z:=0.00;
for var i:=1 to 12 do
begin
Writeln('Доход за ',i,' месяц составил ',a:0:2,'р.');
z+=a;
a:=a+a*0.1;
end;
Writeln('Зарплата за год: ',z:0:2,'р.');
end.
Пример:
Введите зарплату в первый месяц-> 100
Доход за 1 месяц составил 100.00 р.
Доход за 2 месяц составил 110.00 р.
Доход за 3 месяц составил 121.00 р.
Доход за 4 месяц составил 133.10 р.
Доход за 5 месяц составил 146.41 р.
Доход за 6 месяц составил 161.05 р.
Доход за 7 месяц составил 177.16 р.
Доход за 8 месяц составил 194.87 р.
Доход за 9 месяц составил 214.36 р.
Доход за 10 месяц составил 235.79 р.
Доход за 11 месяц составил 259.37 р.
Доход за 12 месяц составил 285.31 р.
Зарплата за год: 2138.43 р
P.S Сделал как понял.
- 23.02.2017 19:31
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.