Вопрос по информатике:
Информатика , 9 класс. Паскаль . Помогите пожалуйста решит. 2. В первый день ученик выучил 3 английских слова, а в каждый следующий день – на 1 слово больше, чем в предыдущий. Составить программу для вычисления количества слов, выученных учеником за неделю.
- 07.12.2017 19:41
- Информатика
- remove_red_eye 2888
- thumb_up 28
Ответы и объяснения 2
begin
k:=3;
s:=3;
for i:=2 to 7 do
begin
k:=k+1;
s:=s+k;
end;
writeln('Количество выученных слов = ',s);
end.
Результат:
Количество выученных слов = 42
- 08.12.2017 01:17
- thumb_up 15
Тогда за n дней он выучит
Теперь можно написать программу. Известно, что k=3, n=7.
Ручной счет дает 3×7+6×7/2 = 21+21 = 42.
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (k,n):=(3,7);
Writeln(k*n+n*(n-1) div 2)
end.
Результат
42
Хорошая иллюстрация случая, когда для решения задачи компьютер не нужен. Так бывает, когда составители заданий думают тем, на чем сидят.
- 09.12.2017 07:54
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.