Вопрос по информатике:
Составить программу , которая в Одномерном массиве размерностью 14 ( элементами являются случайные числа от 10 до 99) находит наименьший элемент оканчивающихся на 1.
- 13.09.2018 23:25
- Информатика
- remove_red_eye 1186
- thumb_up 37
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(14,10,99); a.Println;
var s:=a.Where(x->x mod 10=1);
if s.Count=0 then Writeln('Нет элементов, оканчивающихся на 1')
else Writeln('Наименьший элемент, оканчивающийся на 1: ',s.Min)
end.
Пример
34 32 61 31 56 42 23 89 10 25 59 15 60 73
Наименьший элемент, оканчивающийся на 1: 31
- 14.09.2018 13:23
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.