Вопрос по информатике:
Определите значение переменной р после выполнения следующего фрагмента программы:
m:=13;
n:=21;
n:=2*m-n;
if m< =n then
p:=m+n
else
p:=4-m*n;
Помогите, пожалуйста с заданием по информатике, буду очень благодарна. Желательно расписать так, как это должно выглядеть в программе Pascal.
- 21.08.2017 18:41
- Информатика
- remove_red_eye 8508
- thumb_up 11
Ответы и объяснения 1
n = 21;
n = 2*m-n = 2*13-21 = 26-21 = 5;
m< =n = 13 <= 5 = false ⇒ p = 4-m*n = 4-13*5 = -61
var n,m,p:integer;
begin
m:=13;
n:=21;
n:=2*m-n;
if m<=n then
p:=m+n
else
p:=4-m*n;
writeln(p);
end.
Результат:
-61
- 22.08.2017 01:22
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.