Вопрос по информатике:
В школе N учеников 9 класса писали пробный экзамен по математике. Составить программу, подсчета количества 2,3,4,5, полученных за экзамен. Считайте оценку ученика случайным числом из диапазона от 2 до 5.
- 13.08.2018 06:23
- Информатика
- remove_red_eye 820
- thumb_up 7
Ответы и объяснения 1
A: array[1..200] of byte;
i, N, cTwo, cThree, cFour, cFive: byte;
begin
write('Введите количество учеников(N): '); readln(N);
randomize;
writeln('Все оценки за экзамен.');
for i := 1 to N do
begin
A[i] := random(4)+2;
if A[i] = 2 then cTwo := cTwo + 1;
if A[i] = 3 then cThree := cThree + 1;
if A[i] = 4 then cFour := cFour + 1;
if A[i] = 5 then cFive := cFive + 1;
write(A[i], ' ');
end;
writeln('');
writeln('Оценку 2 получили ', cTwo, ' уч.');
writeln('Оценку 3 получили ', cThree, ' уч.');
writeln('Оценку 4 получили ', cFour, ' уч.');
writeln('Оценку 5 получили ', cFive, ' уч.');
writeln;
end.
- 14.08.2018 16:42
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.