Вопрос по информатике:
1)Дан одномерный массив. Положительные элементы уменьшить в два раза, отрицательные заменить их индексами.
2)Дан одномерный массив. Найти произведение элементов массива.
паскаль
написать программу
если можно блок схему
- 26.12.2017 09:53
- Информатика
- remove_red_eye 18115
- thumb_up 44
Ответы и объяснения 1
//Массивы размеров 10 элементов заполняются случайными числами от -10 до 10
//1
var
A: array[1..10] of real;
i: byte;
begin
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
A[i] := random(21)-10;
write(A[i]:5);
end;
writeln;
writeln('Измененный массив.');
for i := 1 to 10 do
begin
if A[i] > 0 then A[i] := A[i] / 2
else A[i] := i;
write(A[i]:5);
end;
writeln;
end.
//2
var
A: array[1..10] of integer;
i: byte;
mult: longint;
begin
mult := 1;
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
A[i] := random(21)-10;
mult := mult * A[i];
write(A[i]:5);
end;
writeln;
writeln('Произведение элементов массива = ', mult);
end.
- 27.12.2017 07:39
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.