Вопрос по информатике:
В массив с клавиатуры вводятся результаты соревнований по многоборью 7 спортсменов (значениея результатов от 1000 до 2000 баллов). Составить программу которая находит номер и результат победителя
- 15.10.2015 15:14
- Информатика
- remove_red_eye 9512
- thumb_up 25
Ответы и объяснения 1
A: array[1..7] of integer;
i: byte;
Max, MaxInd: integer;
begin
writeln('Заполнение массива. Вводите числа от 1000 до 2000.');
for i := 1 to 7 do
begin
write('A[',i,']=');
readln(A[i]);
if A[i] > Max then
begin
Max := A[i];
MaxInd := i;
end;
end;
writeln;
writeln('№ победителя ', MaxInd, ' результат = ', Max, ' баллов.' );
end.
- 16.10.2015 17:47
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.