Вопрос по информатике:
Напишите программу для работы с массивом позволяющую
1)Создать массив из 16 элементов целого типа, при описании количество элементов использовать именованную константу.
2)заполнить массив случайными числами, не превосходящими 20
3) вывести массив на экран в строку
4) подсчитать количество элементов, меньших 11
- 27.10.2015 08:16
- Информатика
- remove_red_eye 15853
- thumb_up 5
Ответы и объяснения 1
const
n=16;//1-Именованная переменная количество елементов
var
a:array[1..n] of integer;
k:integer;
i:integer;
begin
for i:=1 to n do
a[i]:=random(20);//2-Массив чисел, задал рандомно не больше 20
for i:=1 to n do write(a[i],' ');//3-Вывел массив в строку
for i:=1 to n do
if a[i]<11 then k:=k+1;//4-Подсчитал количество елементов меньше 11
writeln();
writeln();
writeln('Количество елементов меньше 11 = ',k);
end.
- 28.10.2015 07:56
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.