Вопрос по информатике:
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание.Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел.
Дана строка, содержащая пробел. Написать программу, меняющую местами части строки до и после пробела и добавляющую в конец строки вопросительный знак.
- 15.05.2018 09:06
- Информатика
- remove_red_eye 13488
- thumb_up 27
Ответы и объяснения 1
var s:string; p:integer;
begin
readln(s);
p:=pos('_',s);
delete(s,p,1);
insert(', ',s,p);
writeln(s);
end.
Пример:
program_begin
program, begin
2.
var s:string; l,p:integer;
begin
readln(s);
l:=length(s);
p:=pos(' ',s);
s:=copy(s,p+1,l-p+1)+' '+copy(s,1,p-1)+'?';
writeln(s);
end.
Пример:
program begin
begin program?
- 17.05.2018 00:16
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.