Вопрос по информатике:
Помогите решить задачу о Паскалю
Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 включительно. Формат входных данных С клавиатуры вводятся 4 целых числа, по модулю не превосходящих 20. Формат выходных данных Необходимо вывести единственное число — искомое произведение. Если чисел, удовлетворяющих условию, нет, выведите -1.
- 22.03.2018 17:47
- Информатика
- remove_red_eye 2564
- thumb_up 43
Ответы и объяснения 1
begin k := 1; for i := 1 to 4 do begin read(n); if (n >= 3) and (n <= 9) then k := k * n; end; if k = 1 then writeln(-1) else writeln(k);end.
- 23.03.2018 12:26
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.