Вопрос по информатике:
Помогите написать программу по информатике на паскале.
Создать с клавиатуры массив из трех чисел-первое число от 1 до 25, второе от 26 до 50, третье от 51 до 100. Создать второй массив случайным образом по таким же правилам. Сравнить эти числа и написать сколько совпало
- 21.02.2017 04:30
- Информатика
- remove_red_eye 2821
- thumb_up 7
Ответы и объяснения 2
var a,b:mas;
i,k:integer;
procedure proc(var x:mas);
var i:integer;
begin
x[1]:=random(25)+1;
x[2]:=random(25)+26;
x[3]:=random(50)+51;
for i:=1 to 3 do write(x[i],' ');
writeln;
end;
begin
randomize;
writeln('1-й массив:');
proc(a);
writeln('2-й массив:');
proc(b);
k:=0;
for i:=1 to 3 do
if a[i]=b[i] then k:=k+1;
writeln('Число совпавших элементов = ',k);
end.
Пример:
1-й массив:
6 29 58
2-й массив:
21 29 63
Число совпавших элементов = 1
- 22.02.2017 23:26
- thumb_up 21
begin
a[1]:=Random(26); b[1]:=Random(26);
a[2]:=Random(26)+25; b[2]:=Random(26)+25;
a[3]:=Random(51)+50; b[3]:=Random(51)+50;
writeln(a[1],' ',a[2],' ',a[3]);
writeln(b[1],' ',b[2],' ',b[3]);
if (a[1]=b[1]) and (a[2]=b[2]) and (a[3]=b[3])
then writeln('Совпало 3')
else
if ((a[1]=b[1]) and (a[2]=b[2])) or ((a[2]=b[2]) and (a[3]=b[3])) or ((a[1]=b[1]) and (a[3]=b[3]))
then writeln('Совпало 2')
else
if (a[1]=b[1]) or (a[2]=b[2]) or (a[3]=b[3])
then writeln('Совпало 1')
else writeln('Совпадений нет');
end.
P.S Писал не на компьютере, возможны ошибки, проверьте и в случае если обнаружатся ошибки, напишите мне
- 23.02.2017 17:18
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.