- 26.05.2018 13:47
- Информатика
- remove_red_eye 4698
- thumb_up 40
Ответы и объяснения 1
Обратим внимание что в выражении имеется операция возведения в степень, которая в Паскале выполняется с использованием тождества
Итог: алгоритм вычисления - цикл с накоплением суммы и выходом по выполнению условия достижения заданной точности.
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var x:=readReal('Введите x:');
var (s,eps,k):=(0.0,1e-3,1);
while true do begin
var xk:=Power(x,k);
var xs:=xk*xk*Sin(xk)/(k*k);
s+=xs; k+=1;
if (Abs(xs)=MaxReal) then break
end;
Writeln('S=',s)
end.
Примеры
Введите x: -2.5
S=-бесконечность
Введите x: -1
S=-0.69163022624612
Введите x: 0.173
S=0.00515862949420988
Введите x: 2
S=бесконечность
- 27.05.2018 08:55
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.