Вопрос по информатике:
Составьте программу , которая заполняет массив a [1..10] случайными целыми числами в диопозоне от 1 до 20 и находит минемальный элемент массива и его индекс
- 13.05.2018 17:11
- Информатика
- remove_red_eye 17771
- thumb_up 49
Ответы и объяснения 1
var
A: array [1..10] of byte;
i, Min, MinID: byte;
begin
randomize;
Min := 100;
for i := 1 to 10 do
begin
A[i] := random(20) + 1;
if A[i] < Min then
begin
Min := A[i];
MinID := i;
end;
write(A[i], ' ');
end;
writeln;
writeln('Минимальный элемент A[',MinID,'] = ', Min);
readln;
end.
- 14.05.2018 06:55
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.