Вопрос по информатике:
Задано четыре числа: a,b,c,d .Требуется разбить их на две пары,чтобы сумма произведений в этих парах была максимальна
Например,если заданы числа 2,3,4 и 5, то оптимально разбить их на пары (2,3) и (4,5),в этом случае искомая сумма равна 2x3+4x5=26.
Формат входных данных
На вход подаются четыре числа: a.b.c и d.Все числа по модулю не превышают 1000..
Формат выходных данных.
Выведите искомую максимальную сумму.
Примеры
стандартный ввод
2 3 4 5
стандартный вывод
26
- 15.06.2018 03:10
- Информатика
- remove_red_eye 12160
- thumb_up 49
Ответы и объяснения 2
begin
readln(a,b,c,d);
s:=a*b+c*d;
if a*c+b*d>s then s:=a*c+b*d;
if a*d+b*c>s then s:=a*d+b*c;
writeln(s);
// можно вывести полученные пары чисел:
if s=a*b+c*d then writeln('(',a,',',b,') и (',c,',',d,')')
else if s=a*c+b*d then writeln('(',a,',',c,') и (',b,',',d,')')
else writeln('(',a,',',d,') и (',b,',',c,')')
end.
Пример:
2 3 4 5
26
(2,3) и (4,5)
- 17.06.2018 14:04
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.