Вопрос по информатике:
Срочно. В простой понятной форме. Напишите программу, которая заполняет массив случайными числами в диапазоне [a, b] и сортирует его “домиком” – до половины в порядке возрастания, затем – в порядке убывания. Количество элементов в массиве может быть любое! С объяснениями и откуда что взялось?
- 27.08.2018 02:33
- Информатика
- remove_red_eye 6486
- thumb_up 7
Ответы и объяснения 1
A: array [1..255] of integer;
N, i, j, k, min, max: integer;
begin
//Ввод количества элементов в массиве
write('Введите четное количество элементов: ');
readln(N);
//Ввод двух чисел для диапазона случайных чисел
write('Введите диапазон случайных чисел: ');
readln(min, max);
//Инициализация датчика случайных чисел.
//(в PascalABC.NET необязательно)
randomize;
//Заполнение массива
for i := 1 to N do
begin
A[i] := random(max-min+1)+min;
write(A[i]:4);
end;
writeln;
//Сортировка первой половины по убыванию
for i := 1 to ((N div 2)-1) do
for j := 1 to (N div 2)-i do
if A[j] > A[j+1] then
begin
k := A[j];
A[j] := A[j+1];
A[j+1] := k;
end;
//Сортировка второй половины по убыванию
for i:=(N div 2) to N-1 do
for j:=i+1 to N do
if A[i] begin
k:=a[i];
A[i]:=A[j];
A[j]:=k;
end;
//Вывод массива
for i := 1 to N do write(A[i]:4);
writeln;
readln;
end.
- 28.08.2018 13:31
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.