Вопрос по информатике:
1. Определите, что делает следующая программа и какой результат она выдаст на заданном массиве (1,4,0,-1,6).
Var a:array[1..5] of integer; i, b:integer;
begin
b:=a[ 1 ];
for i:=2 to n do if a[i]>b then b:=a[i];
writeln(b)
end.
2. Чему будет равно значение k после выполнения программы?
Var
m, k:integer;
begin
m:=0; k:=1;
while (m<5) do m:=m+1; k:=k+m;
writeln(k);
end.
Варианты ответов: а) 2;
б) 3;
в) 4;
г) 5.
Заранее спасибо!
- 12.10.2017 02:03
- Информатика
- remove_red_eye 1358
- thumb_up 28
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.