Вопрос по информатике:
Составить программу,которая заполняет массив a(1..20) случайными числами [-2;2]Вычислить произведение отрицательных элементов массива с индексами от n до m включительно(n,m вводятся с клавиатуры)
- 02.02.2015 19:32
- Информатика
- remove_red_eye 1165
- thumb_up 22
Ответы и объяснения 1
//Если программа не запускается, то обновите версию
begin
var a := ArrRandomInteger(20, -2, 2);
Writeln(a);
var n := ReadInteger('n=');
var m := ReadInteger('m=');
a := a.Skip(n - 1).Take(m - n).ToArray();
Writeln(a);
if a.Any(x -> x < 0) then
writeln(a.Where(x -> x x * y));
end.
- 03.02.2015 02:52
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.